NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
HIGH severity

Paranoidhttp Server-Side Request Forgery vulnerabilityGHSA-v9mp-j8g7-2q6m

HIGHFix: hakobe/paranoidhttp@07f671d

GHSA-v9mp-j8g7-2q6m is a high-severity (CVSS 7.5) Server-Side Request Forgery (SSRF) vulnerability in github.com/hakobe/paranoidhttp. A fix is available for github.com/hakobe/paranoidhttp — see the affected versions and patch details below.

Also known asCVE-2023-24623GO-2023-1526
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-v9mp-j8g7-2q6m.

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs53th percentile — riskier than 53% of all scored CVEsHighest risk
0.00%0.39%0.79%1.18%0.2%0.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐹github.com/hakobe/paranoidhttp

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Paranoidhttp before 0.3.0 allows SSRF because [::] is equivalent to the 127.0.0.1 address, but does not match the filter for private addresses.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/hakobe/paranoidhttpall versions0.3.0go get github.com/hakobe/paranoidhttp@v0.3.0

Affected Products

1 product · 1 configurations
Application
paranoidhttpparanoidhttp_project
< 0.3.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/hakobe/paranoidhttp, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/hakobe/paranoidhttp to 0.3.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-v9mp-j8g7-2q6m is resolved across your whole dependency graph.

  3. Workarounds

    Restrict outbound requests from the affected component to an allowlist of hosts, block access to link-local and internal address ranges at the network layer, and require authentication on internal services so a forged request cannot reach them unauthenticated.

Frequently Asked Questions

Paranoidhttp before 0.3.0 allows SSRF because [::] is equivalent to the 127.0.0.1 address, but does not match the filter for private addresses.
O3 Security · Impact-Aware SCA

Is GHSA-v9mp-j8g7-2q6m in your dependencies?

Find it across Go, including transitive dependencies.

Paranoidhttp Server-Side Request Forgery vulnerability