NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

Cleartext Storage of Sensitive Information in HMAC SHA256 AuthenticationGHSA-v427-c49j-8w6x

MEDIUMFix: codeigniter4/shield@f77c6ae

GHSA-v427-c49j-8w6x is a medium-severity (CVSS 5) CWE-312 vulnerability in codeigniter4/shield. A fix is available for codeigniter4/shield — see the affected versions and patch details below.

Also known asCVE-2023-48707
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 7, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs21th percentile — riskier than 21% of all scored CVEsHighest risk
0.00%0.26%0.52%0.78%0.1%0.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘codeigniter4/shield

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Impact

secretKey, an important key for HMAC SHA256 authentication, was stored in the database in raw form.

If a malicious person somehow had access to the data in the database, they could use the key and secretKey for HMAC SHA256 authentication to send requests impersonating that person.

Patches

Upgrade to Shield v1.0.0-beta.8 or later.

After upgrading, all existing secret keys must be encrypted. See https://github.com/codeigniter4/shield/blob/develop/UPGRADING.md for details.

Workarounds

None.

References

For more information

If you have any questions or comments about this advisory:

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistcodeigniter4/shieldall versions1.0.0-beta.8composer require codeigniter4/shield:^1.0.0-beta.8

Affected Products

1 product · 7 configurations
Application
shieldcodeigniter
1 version
1.0.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for codeigniter4/shield, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update codeigniter4/shield to 1.0.0-beta.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-v427-c49j-8w6x is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

### Impact **secretKey**, an important key for HMAC SHA256 authentication, was stored in the database in raw form. If a malicious person somehow had access to the data in the database, they could use the key and secretKey for HMAC SHA256 authentication to send requests impersonating that person. ### Patches Upgrade to Shield v1.0.0-beta.8 or later. After upgrading, all existing secret keys must be encrypted. See https://github.com/codeigniter4/shield/blob/develop/UPGRADING.md for details. ### Workarounds None. ### References - https://codeigniter4.github.io/shield/references/authenticatio
O3 Security · Impact-Aware SCA

Is GHSA-v427-c49j-8w6x in your dependencies?

Find it across Packagist, including transitive dependencies.

Cleartext Storage of Sensitive Information in HMAC…