NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

Python Charmers Future denial of service vulnerabilityGHSA-v3c5-jqr6-7qm8

HIGHFix: PythonCharmers/python-future#610

GHSA-v3c5-jqr6-7qm8 is a high-severity (CVSS 7.5) Uncontrolled Resource Consumption vulnerability in future. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for future — see the affected versions and patch details below.

Also known asCVE-2022-40899PYSEC-2022-42991
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
2 known
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.

Exploitation and automatability from CISA’s SSVC triage for GHSA-v3c5-jqr6-7qm8.

EPSS Exploitation Probability

via FIRST.org ↗
1.9%probability of exploitation in next 30 days
Lower Risk+0.11%
Lower risk than most CVEs80th percentile — riskier than 80% of all scored CVEsHighest risk
0.00%0.81%1.62%2.43%0.4%1.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍future

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

An issue discovered in Python Charmers Future 0.18.2 and earlier allows remote attackers to cause a denial of service via crafted Set-Cookie header from malicious web server. This issue has been patched in version 0.18.3.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIfutureall versions0.18.3pip install --upgrade 'future==0.18.3'

Affected Products

1 product · 1 configurations
Application
python-futurepythoncharmers
≤ 0.18.2
range
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for future, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update future to 0.18.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-v3c5-jqr6-7qm8 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Red Hat Satellite 6.13 for RHEL 8python-future-0:0.18.3-1.el8pcRHSA-2023:4466
Red Hat Satellite 6.14 for RHEL 8python-future-0:0.18.3-1.el8pcRHSA-2023:6818
RHUI 4 for RHEL 8python-future-0:0.18.3-1.0.1.el8uiRHSA-2023:2101

Frequently Asked Questions

An issue discovered in Python Charmers Future 0.18.2 and earlier allows remote attackers to cause a denial of service via crafted Set-Cookie header from malicious web server. This issue has been patched in version 0.18.3.
O3 Security · Impact-Aware SCA

Is GHSA-v3c5-jqr6-7qm8 in your dependencies?

Find it across PyPI, including transitive dependencies.

Python Charmers Future denial of service vulnerability