CVE-2022-40899 is a high-severity (CVSS 7.5) Uncontrolled Resource Consumption vulnerability in future. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for future — see the affected versions and patch details below.
Python Charmers Future denial of service vulnerability
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-40899.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
futureReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
An issue discovered in Python Charmers Future 0.18.2 and earlier allows remote attackers to cause a denial of service via crafted Set-Cookie header from malicious web server. This issue has been patched in version 0.18.3.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | future | all versions | 0.18.3pip install --upgrade 'future==0.18.3' |
Affected Products
python-futurepythoncharmersResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for future, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update future to 0.18.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-40899 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Satellite 6.13 for RHEL 8 | python-future-0:0.18.3-1.el8pc | RHSA-2023:4466 |
| Red Hat Satellite 6.14 for RHEL 8 | python-future-0:0.18.3-1.el8pc | RHSA-2023:6818 |
| RHUI 4 for RHEL 8 | python-future-0:0.18.3-1.0.1.el8ui | RHSA-2023:2101 |
Frequently Asked Questions
Is CVE-2022-40899 in your dependencies?
Find it across PyPI, including transitive dependencies.