NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦 npm
Not in CISA KEV

canvg Prototype Pollution vulnerabilityGHSA-v2mw-5mch-w8c5

Fix: canvg/canvg@c3743e6

GHSA-v2mw-5mch-w8c5 is a CWE-1321 vulnerability in canvg. A fix is available for canvg — see the affected versions and patch details below.

Also known asCVE-2025-25977
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • A successful exploit gives an attacker total control of the affected component, not partial access.

Exploitation and automatability from CISA’s SSVC triage for GHSA-v2mw-5mch-w8c5.

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs54th percentile — riskier than 54% of all scored CVEsHighest risk
0.00%0.40%0.81%1.21%0.3%0.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

2 pkgs affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

347other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
canvgnpm
20.7Mdownloads / week

Description

An issue in canvg prior to v.4.0.3 and v3.0.11 can lead to prototype pollution via the Constructor of the class StyleElement.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
📦npmcanvg≥ 4.0.0&&< 4.0.34.0.3npm install canvg@4.0.3
📦npmcanvgall versions3.0.11npm install canvg@3.0.11

Affected Products

1 product · 2 configurations
Application
canvgcanvg
≥ 4.0.0 && < 4.0.3
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for canvg, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update canvg to 4.0.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-v2mw-5mch-w8c5 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

An issue in canvg prior to v.4.0.3 and v3.0.11 can lead to prototype pollution via the Constructor of the class StyleElement.
O3 Security · Impact-Aware SCA

Is GHSA-v2mw-5mch-w8c5 in your dependencies?

Find it across npm, including transitive dependencies.

canvg Prototype Pollution vulnerability