NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💎
💎 RubyGems
Not in CISA KEV
MEDIUM severity

Decidim::Admin vulnerable to cross-site scripting (XSS) in the admin activity logGHSA-rx9f-5ggv-5rh6

MEDIUMFix: decidim/decidim@23fc8d7

GHSA-rx9f-5ggv-5rh6 is a medium-severity (CVSS 6.8) Cross-site Scripting (XSS) vulnerability in decidim-admin. A fix is available for decidim-admin — see the affected versions and patch details below.

Also known asCVE-2024-32034
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-rx9f-5ggv-5rh6.

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs32th percentile — riskier than 32% of all scored CVEsHighest risk
0.00%0.36%0.71%1.07%0.6%0.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
💎decidim-admin💎decidim-admin

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.

Description

decidim is a Free Open-Source participatory democracy, citizen participation and open government for cities and organizations. The admin panel is subject to potential Cross-site scripting (XSS) attach in case an admin assigns a valuator to a proposal, or does any other action that generates an admin activity log where one of the resources has an XSS crafted. This issue has been addressed in release version 0.27.7, 0.28.2, and newer. Users are advised to upgrade. Users unable to upgrade may redirect the pages /admin and /admin/logs to other admin pages to prevent this access (i.e. /admin/organization/edit).

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
💎RubyGemsdecidim-adminall versions0.27.7bundle update decidim-admin --conservative
💎RubyGemsdecidim-admin≥ 0.28.0&&< 0.28.20.28.2bundle update decidim-admin --conservative

Affected Products

1 product · 3 configurations
Application
decidimdecidim
< 0.27.7
2 versions
0.28.00.28.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for decidim-admin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update decidim-admin to 0.27.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-rx9f-5ggv-5rh6 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

### Impact The admin panel is subject to potential XSS attach in case an admin assigns a valuator to a proposal, or does any other action that generates an admin activity log where one of the resources has an XSS crafted. ### Patches N/A ### Workarounds Redirect the pages /admin and /admin/logs to other admin pages to prevent this access (i.e. `/admin/organization/edit`) ### References OWASP ASVS v4.0.3-5.1.3
O3 Security · Impact-Aware SCA

Is GHSA-rx9f-5ggv-5rh6 in your dependencies?

Find it across RubyGems, including transitive dependencies.

Decidim::Admin vulnerable to cross-site scripting (XSS) in…