CVE-2024-27095 — decidim-admin
MEDIUMCVE-2024-27095 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in decidim-admin. A fix is available for decidim-admin — see the affected versions and patch details below.
Decidim cross-site scripting (XSS) in the admin panel
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-27095.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
decidim-admin💎decidim-adminReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.
Description
Impact
The admin panel is subject to potential XSS attach in case the attacker manages to modify some records being uploaded to the server.
The attacker is able to change e.g. to <svg onload=alert('XSS')> if they know how to craft these requests themselves. And then enter the returned blob ID to the form inputs manually by modifying the edit page source.
Patches
Available in versions 0.27.6 and 0.28.1.
Workarounds
Review the user accounts that have access to the admin panel (i.e. general Administrators, and participatory space's Administrators) and remove access to them if they don't need it.
References
OWASP ASVS v4.0.3-5.1.3
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 💎RubyGems | decidim-admin | all versions | 0.27.6bundle update decidim-admin --conservative |
| 💎RubyGems | decidim-admin | ≥ 0.28.0.rc1&&< 0.28.1 | 0.28.1bundle update decidim-admin --conservative |
Affected Products
decidimdecidimDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for decidim-admin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update decidim-admin to 0.27.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-27095 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2024-27095 in your dependencies?
Find it across RubyGems, including transitive dependencies.