NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍 PyPI
Not in CISA KEV

loggingredactor converts non-string types to string types in logsGHSA-rvjx-cfjh-5mc9

GHSA-rvjx-cfjh-5mc9 is a CWE-704 vulnerability in loggingredactor. A fix is available for loggingredactor — see the affected versions and patch details below.

Also known asCVE-2026-22041PYSEC-2026-1582
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.

Exploitation and automatability from CISA’s SSVC triage for GHSA-rvjx-cfjh-5mc9.

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs20th percentile — riskier than 20% of all scored CVEsHighest risk
0.00%0.26%0.51%0.77%0.0%0.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
🐍loggingredactor

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Impact

Non-string types are converted into string types, leading to type errors in %d conversions.

Patches

The problem has been patched in version 0.0.6.

Workarounds

None without patching.

Resources

Issue report: https://github.com/armurox/loggingredactor/issues/7 Release: https://github.com/armurox/loggingredactor/releases/tag/0.0.6

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIloggingredactorall versions0.0.6pip install --upgrade 'loggingredactor==0.0.6'

Affected Products

1 product · 1 configurations
Application
logging redactorarmurox
< 0.0.6
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for loggingredactor, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update loggingredactor to 0.0.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-rvjx-cfjh-5mc9 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

### Impact Non-string types are converted into string types, leading to type errors in %d conversions. ### Patches The problem has been patched in version 0.0.6. ### Workarounds None without patching. ### Resources Issue report: https://github.com/armurox/loggingredactor/issues/7 Release: https://github.com/armurox/loggingredactor/releases/tag/0.0.6
O3 Security · Impact-Aware SCA

Is GHSA-rvjx-cfjh-5mc9 in your dependencies?

Find it across PyPI, including transitive dependencies.

GHSA-rvjx-cfjh-5mc9: loggingredactor — Fixed in 0.0.6