NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍 PyPI
Not in CISA KEV

Insufficient HTML SanitizationGHSA-rm89-9g65-4ffr

GHSA-rm89-9g65-4ffr is a security vulnerability in inventree. A fix is available for inventree — see the affected versions and patch details below.

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Dec 8, 2024 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

1 pkg affected
🐍inventree

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Impact

Affected versions can have malicious javascript code injected into the users browser by other authenticated users, as data fields retrieved from the database are not properly sanitized before displaying in various front-end views.

The problem here stems from multiple issues:

  • Insufficient database sanitation on multiple fields allows injection of un-sanitized HTML
  • Lack of HTML escaping when rendering data on the front end

The attack vector here is limited, as only authenticated users are able to write data to the database, for it to be subsequently rendered on the front-end. However, it is a vulnerability that the InvenTree development team takes seriously.

Solution

The proposed patch for this vulnerability is prevents injection of un-escaped fields into front-end UI elements.

A future patch will also address sanitization of database fields on the "back end", however this will require a much larger effort to refactor multiple database tables.

Patches

  • The issue is addressed in the upcoming 0.8.0 release
  • This fix will also be back-ported to the 0.7.x branch, applied to the 0.7.2 release

Workarounds

There are no workarounds for this issue, users should upgrade to a patched version.

References

Thank you @saharshtapi for bringing this issue to our attention and giving pointers for fixing them.

For more information

If you have any questions or comments about this advisory:

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIinventreeall versions0.7.2pip install --upgrade 'inventree==0.7.2'

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for inventree, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update inventree to 0.7.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-rm89-9g65-4ffr is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

### Impact Affected versions can have malicious javascript code injected into the users browser by other authenticated users, as data fields retrieved from the database are not properly sanitized before displaying in various front-end views. The problem here stems from multiple issues: - Insufficient database sanitation on multiple fields allows injection of un-sanitized HTML - Lack of HTML escaping when rendering data on the front end The attack vector here is limited, as only authenticated users are able to write data to the database, for it to be subsequently rendered on the front-end.
O3 Security · Impact-Aware SCA

Is GHSA-rm89-9g65-4ffr in your dependencies?

Find it across PyPI, including transitive dependencies.

Insufficient HTML Sanitization