NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍 PyPI
Not in CISA KEV

XSS Vulnerability in Markdown EditorGHSA-85q9-7467-r53q

GHSA-85q9-7467-r53q is a security vulnerability in inventree. A fix is available for inventree — see the affected versions and patch details below.

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of May 5, 2026 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

1 pkg affected
🐍inventree

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Impact

InvenTree uses EasyMDE for displaying markdown text in various places (e.g. for the various "notes" fields associated with various models).

By default, EasyMDE does not sanitize input data, and it is possible for malicious code to be injected into the markdown editor, and executed in the users browser.

Note: This malicious data must be first uploaded to the database by an authorized user, so the risk here is limited to trusted users

Solution

The solution here is two-fold:

  • Enable data sanitization for the EasyMDE renderer - #3205
  • Enforce cleaning of all data uploaded to the database via the API - #3204 (This will be ready for the 0.8.0 release)

Patches

  • The issue is addressed in the 0.8.0 release
  • This fix was back-ported to the 0.7.x branch, applied to the 0.7.3 release

Workarounds

There is no workaround for this issue without upgrading InvenTree to the specified version.

References

For more information

If you have any questions or comments about this advisory:

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIinventreeall versions0.7.3pip install --upgrade 'inventree==0.7.3'

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for inventree, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update inventree to 0.7.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-85q9-7467-r53q is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

### Impact InvenTree uses [EasyMDE](https://github.com/Ionaru/easy-markdown-editor) for displaying markdown text in various places (e.g. for the various "notes" fields associated with various models). By default, EasyMDE does not sanitize input data, and it is possible for malicious code to be injected into the markdown editor, and executed in the users browser. *Note: This malicious data must be first uploaded to the database by an authorized user, so the risk here is limited to trusted users* ### Solution The solution here is two-fold: - Enable data sanitization for the EasyMDE rendere
O3 Security · Impact-Aware SCA

Is GHSA-85q9-7467-r53q in your dependencies?

Find it across PyPI, including transitive dependencies.

XSS Vulnerability in Markdown Editor