NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

element-plus vulnerable to cross-site scripting (XSS) via el-table-columnGHSA-rjvg-8v36-xv9r

MEDIUMFix: element-plus/element-plus#6520

GHSA-rjvg-8v36-xv9r is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in element-plus. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for element-plus — see the affected versions and patch details below.

Also known asCVE-2022-27103
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
2 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs60th percentile — riskier than 60% of all scored CVEsHighest risk
0.00%0.46%0.93%1.39%0.3%0.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

5Kother npm packages depend on this — each one inherits the vulnerability until it's patched upstream
element-plusnpm
766Kdownloads / week

Description

element-plus below 2.0.5 is vulnerable to Cross Site Scripting (XSS) when attribute show-tooltips-overflow of el-table-column is true. The mouseover action will make the text of this column render as html.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmelement-plusall versions2.0.6npm install element-plus@2.0.6

Affected Products

1 product · 1 configurations
Application
element-pluselement-plus
1 version
2.0.5
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for element-plus, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update element-plus to 2.0.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-rjvg-8v36-xv9r is resolved across your whole dependency graph.

  3. Workarounds

    Constrain what reaches the vulnerable code: limit the size and shape of untrusted input, isolate the affected component in a sandboxed or least-privileged process, and enable the platform's memory-safety mitigations (ASLR, stack protector, hardened allocator) so an out-of-bounds access is more likely to fail closed than to be exploitable.

Frequently Asked Questions

element-plus below 2.0.5 is vulnerable to Cross Site Scripting (XSS) when attribute `show-tooltips-overflow` of `el-table-column` is true. The mouseover action will make the text of this column render as html.
O3 Security · Impact-Aware SCA

Is GHSA-rjvg-8v36-xv9r in your dependencies?

Find it across npm, including transitive dependencies.

element-plus vulnerable to cross-site scripting (XSS) via…