CVE-2022-27103 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in element-plus. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for element-plus — see the affected versions and patch details below.
element-plus vulnerable to cross-site scripting (XSS) via el-table-column
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
element-plusnpmDescription
element-plus below 2.0.5 is vulnerable to Cross Site Scripting (XSS) when attribute show-tooltips-overflow of el-table-column is true. The mouseover action will make the text of this column render as html.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | element-plus | all versions | 2.0.6npm install element-plus@2.0.6 |
Affected Products
element-pluselement-plusResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for element-plus, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update element-plus to 2.0.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-27103 is resolved across your whole dependency graph.
Workarounds
Constrain what reaches the vulnerable code: limit the size and shape of untrusted input, isolate the affected component in a sandboxed or least-privileged process, and enable the platform's memory-safety mitigations (ASLR, stack protector, hardened allocator) so an out-of-bounds access is more likely to fail closed than to be exploitable.
Frequently Asked Questions
Is CVE-2022-27103 in your dependencies?
Find it across npm, including transitive dependencies.