NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

@diplodoc/search-extension allows stored XSS via Markdown file titleGHSA-rjmp-rwj4-mv82

MEDIUMFix: diplodoc-platform/search-extension#41

GHSA-rjmp-rwj4-mv82 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in @diplodoc/search-extension. A fix is available for @diplodoc/search-extension — see the affected versions and patch details below.

Also known asCVE-2026-40201
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-rjmp-rwj4-mv82.

EPSS Exploitation Probability

via FIRST.org ↗
0.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs15th percentile — riskier than 15% of all scored CVEsHighest risk
0.00%0.27%0.53%0.80%0.0%0.2%May 26Sep 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

2other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
@diplodoc/search-extensionnpm
823downloads / week

Description

@diplodoc/search-extension 1.0.0 through 3.x before 3.0.3 allows stored XSS via the title in a .md file.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npm@diplodoc/search-extension≥ 1.0.0&&< 3.0.53.0.5npm install @diplodoc/search-extension@3.0.5

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @diplodoc/search-extension, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update @diplodoc/search-extension to 3.0.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-rjmp-rwj4-mv82 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

@diplodoc/search-extension 1.0.0 through 3.0.2 allows stored XSS via .md file title.
O3 Security · Impact-Aware SCA

Is GHSA-rjmp-rwj4-mv82 in your dependencies?

Find it across npm, including transitive dependencies.