CVE-2026-40201 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in @diplodoc/search-extension. A fix is available for @diplodoc/search-extension — see the affected versions and patch details below.
@diplodoc/search-extension allows stored XSS via Markdown file title
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-40201.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
@diplodoc/search-extensionnpmDescription
@diplodoc/search-extension 1.0.0 through 3.x before 3.0.3 allows stored XSS via the title in a .md file.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | @diplodoc/search-extension | ≥ 1.0.0&&< 3.0.5 | 3.0.5npm install @diplodoc/search-extension@3.0.5 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @diplodoc/search-extension, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update @diplodoc/search-extension to 3.0.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-40201 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2026-40201 in your dependencies?
Find it across npm, including transitive dependencies.