NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

Silverstripe Flash Clipboard Reflected XSSGHSA-rfvw-5848-gxc5

MEDIUMFix: silverstripe/silverstripe-admin@6e6fa5c

GHSA-rfvw-5848-gxc5 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in silverstripe/framework. A fix is available for silverstripe/framework — see the affected versions and patch details below.

Also known asCVE-2019-12205
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Oct 28, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs59th percentile — riskier than 59% of all scored CVEsHighest risk
0.00%0.46%0.92%1.38%0.4%0.9%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐘silverstripe/framework🐘silverstripe/admin🐘silverstripe/framework

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

SilverStripe versions 3.0.0 until 4.3.5 and 4.4.4 are vulnerable to Flash Clipboard Reflected XSS. Versions 4.3.5 and 4.4.4 of silverstripe/framework and version 1.3.5 of silverstripe/admin contain a fix for this issue.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistsilverstripe/framework≥ 3.0.0&&< 4.3.54.3.5composer require silverstripe/framework:^4.3.5
🐘Packagistsilverstripe/adminall versions1.3.5composer require silverstripe/admin:^1.3.5
🐘Packagistsilverstripe/framework≥ 4.4.0-rc1&&< 4.4.44.4.4composer require silverstripe/framework:^4.4.4

Affected Products

1 product · 1 configurations
Application
silverstripesilverstripe
≤ 4.3.3
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for silverstripe/framework, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update silverstripe/framework to 4.3.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-rfvw-5848-gxc5 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

SilverStripe versions 3.0.0 until 4.3.5 and 4.4.4 are vulnerable to Flash Clipboard Reflected XSS. Versions 4.3.5 and 4.4.4 of `silverstripe/framework` and version 1.3.5 of `silverstripe/admin` contain a fix for this issue.
O3 Security · Impact-Aware SCA

Is GHSA-rfvw-5848-gxc5 in your dependencies?

Find it across Packagist, including transitive dependencies.

Silverstripe Flash Clipboard Reflected XSS (Medium 6.1)