NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

Privilege escalation by backend users assigned to the default "Publisher" system roleGHSA-rfjc-xrmf-5vvw

MEDIUMFix: octobercms/october@4c650bb

GHSA-rfjc-xrmf-5vvw is a medium-severity (CVSS 4) CWE-863 vulnerability in october/backend. A fix is available for october/backend — see the affected versions and patch details below.

Also known asCVE-2020-15248
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs24th percentile — riskier than 24% of all scored CVEsHighest risk
0.00%0.27%0.54%0.81%0.0%0.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘october/backend

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Impact

Backend users with the default "Publisher" system role have access to create & manage users where they can choose which role the new user has. This means that a user with "Publisher" access has the ability to escalate their access to "Developer" access.

Patches

Issue has been patched in Build 470 (v1.0.470) & v1.1.1.

Workarounds

Apply https://github.com/octobercms/october/commit/78a37298a4ed4602b383522344a31e311402d829 to your installation manually if unable to upgrade to Build 470 or v1.1.1.

References

Reported by Hoan Hoang

For more information

If you have any questions or comments about this advisory:

Threat assessment:

<img width="1098" alt="Screen Shot 2020-10-10 at 1 37 25 PM" src="https://user-images.githubusercontent.com/7253840/95663611-e6326c80-0afd-11eb-8a1e-8b767a7202fb.png">

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistoctober/backend≥ 1.0.319&&< 1.0.4701.0.470composer require october/backend:^1.0.470

Affected Products

1 product · 1 configurations
Application
octoberoctobercms
≥ 1.0.319 && < 1.0.469
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for october/backend, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update october/backend to 1.0.470 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-rfjc-xrmf-5vvw is resolved across your whole dependency graph.

  3. Workarounds

    Close the privilege gap rather than the entry point: audit which accounts, roles and service identities can reach the affected operation, drop the component to the least privilege it actually needs, and review file and directory permissions created by earlier installs — a default left in place is what makes this reachable.

Frequently Asked Questions

### Impact Backend users with the default "Publisher" system role have access to create & manage users where they can choose which role the new user has. This means that a user with "Publisher" access has the ability to escalate their access to "Developer" access. ### Patches Issue has been patched in Build 470 (v1.0.470) & v1.1.1. ### Workarounds Apply https://github.com/octobercms/october/commit/78a37298a4ed4602b383522344a31e311402d829 to your installation manually if unable to upgrade to Build 470 or v1.1.1. ### References Reported by [Hoan Hoang](https://github.com/hoanhp) ### For mor
O3 Security · Impact-Aware SCA

Is GHSA-rfjc-xrmf-5vvw in your dependencies?

Find it across Packagist, including transitive dependencies.

Privilege escalation by backend users assigned to the…