NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

Improper Input Validation in url-jsGHSA-rf54-44jr-q5vf

MEDIUMFix: duzun/URL.js@9dc9fcc

GHSA-rf54-44jr-q5vf is a medium-severity (CVSS 5.3) Improper Input Validation vulnerability in url-js. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for url-js — see the affected versions and patch details below.

Also known asCVE-2022-25839SNYK-JS-URLJS-2414030
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Sep 29, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs57th percentile — riskier than 57% of all scored CVEsHighest risk

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

1other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
url-jsnpm
157downloads / week

Description

The package url-js before 2.1.0 are vulnerable to Improper Input Validation due to improper parsing, which makes it is possible for the hostname to be spoofed. http://\\\\localhost and http://localhost are the same URL. However, the hostname is not parsed as localhost, and the backslash is reflected as it is.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmurl-jsall versions2.1.0npm install url-js@2.1.0

Affected Products

1 product · 1 configurations
Application
url-jsurl-js_project
< 2.1.0
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for url-js, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update url-js to 2.1.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-rf54-44jr-q5vf is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

The package url-js before 2.1.0 is vulnerable to Improper Input Validation due to improper parsing, which makes it is possible for the hostname to be spoofed. http://\\\\\\\\localhost and http://localhost are the same URL. However, the hostname is not parsed as localhost, and the backslash is reflected as it is.
O3 Security · Impact-Aware SCA

Is GHSA-rf54-44jr-q5vf in your dependencies?

Find it across npm, including transitive dependencies.

Improper Input Validation in url-js (Medium 5.3)