NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

Apache Pulsar Kafka Connector Logs Sensitive Information in Application LogsGHSA-rcqj-3fmp-5cqx

MEDIUMFix: apache/pulsar#24128

GHSA-rcqj-3fmp-5cqx is a medium-severity (CVSS 6.5) CWE-532 vulnerability in org.apache.pulsar:pulsar-io-kafka-connect-adaptor. A fix is available for org.apache.pulsar:pulsar-io-kafka-connect-adaptor — see the affected versions and patch details below.

Also known asCVE-2025-30677
Published
Updated
Affected
6 pkgs
Patched
6 / 6
Exploits
None indexed
Exploitation data as of Nov 7, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-rcqj-3fmp-5cqx.

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk+0.01%
Lower risk than most CVEs55th percentile — riskier than 55% of all scored CVEsHighest risk
0.00%0.41%0.83%1.24%0.3%0.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

6 pkgs affected
☕org.apache.pulsar:pulsar-io-kafka-connect-adaptor☕org.apache.pulsar:pulsar-io-kafka-connect-adaptor☕org.apache.pulsar:pulsar-io-kafka-connect-adaptor☕org.apache.pulsar:pulsar-io-kafka☕org.apache.pulsar:pulsar-io-kafka☕org.apache.pulsar:pulsar-io-kafka

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Apache Pulsar contains multiple connectors for integrating with Apache Kafka. The Pulsar IO Apache Kafka Source Connector, Sink Connector, and Kafka Connect Adaptor Sink Connector log sensitive configuration properties in plain text in application logs.

This vulnerability can lead to unintended exposure of credentials in log files, potentially allowing attackers with access to these logs to obtain Apache Kafka credentials. The vulnerability's impact is limited by the fact that an attacker would need access to the application logs to exploit this issue.

This issue affects Apache Pulsar IO's Apache Kafka connectors in all versions before 3.0.11, 3.3.6, and 4.0.4.

3.0.x version users should upgrade to at least 3.0.11.

3.3.x version users should upgrade to at least 3.3.6.

4.0.x version users should upgrade to at least 4.0.4.

Users operating versions prior to those listed above should upgrade to the aforementioned patched versions or newer versions.

Affected Packages

6 total 6 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.pulsar:pulsar-io-kafka-connect-adaptorall versions3.0.11org.apache.pulsar:pulsar-io-kafka-connect-adaptor:3.0.11
☕Mavenorg.apache.pulsar:pulsar-io-kafka-connect-adaptor≥ 3.3.0&&< 3.3.63.3.6org.apache.pulsar:pulsar-io-kafka-connect-adaptor:3.3.6
☕Mavenorg.apache.pulsar:pulsar-io-kafka-connect-adaptor≥ 4.0.0&&< 4.0.44.0.4org.apache.pulsar:pulsar-io-kafka-connect-adaptor:4.0.4
☕Mavenorg.apache.pulsar:pulsar-io-kafkaall versions3.0.11org.apache.pulsar:pulsar-io-kafka:3.0.11
☕Mavenorg.apache.pulsar:pulsar-io-kafka≥ 3.3.0&&< 3.3.63.3.6org.apache.pulsar:pulsar-io-kafka:3.3.6
☕Mavenorg.apache.pulsar:pulsar-io-kafka≥ 4.0.0&&< 4.0.44.0.4org.apache.pulsar:pulsar-io-kafka:4.0.4

Affected Products

1 product · 3 configurations
Application
pulsarapache
≥ 4.0.0 && < 4.0.4
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.pulsar:pulsar-io-kafka-connect-adaptor, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.pulsar:pulsar-io-kafka-connect-adaptor to 3.0.11 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-rcqj-3fmp-5cqx is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Apache Pulsar contains multiple connectors for integrating with Apache Kafka. The Pulsar IO Apache Kafka Source Connector, Sink Connector, and Kafka Connect Adaptor Sink Connector log sensitive configuration properties in plain text in application logs. This vulnerability can lead to unintended exposure of credentials in log files, potentially allowing attackers with access to these logs to obtain Apache Kafka credentials. The vulnerability's impact is limited by the fact that an attacker would need access to the application logs to exploit this issue. This issue affects Apache Pulsar IO's
O3 Security · Impact-Aware SCA

Is GHSA-rcqj-3fmp-5cqx in your dependencies?

Find it across Maven, including transitive dependencies.

Apache Pulsar Kafka Connector Logs Sensitive…