CVE-2025-30677 — pulsar-io-kafka-connect-a…
Fix: apache/pulsar#24128CVE-2025-30677 is a CWE-532 vulnerability in org.apache.pulsar:pulsar-io-kafka-connect-adaptor. A fix is available for org.apache.pulsar:pulsar-io-kafka-connect-adaptor — see the affected versions and patch details below.
Apache Pulsar IO Kafka Connector, Apache Pulsar IO Kafka Connect Adaptor: Sensitive information logged in Pulsar's Apache Kafka Connectors
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-30677.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
org.apache.pulsar:pulsar-io-kafka-connect-adaptor☕org.apache.pulsar:pulsar-io-kafka-connect-adaptor☕org.apache.pulsar:pulsar-io-kafka-connect-adaptor☕org.apache.pulsar:pulsar-io-kafka☕org.apache.pulsar:pulsar-io-kafka☕org.apache.pulsar:pulsar-io-kafkaReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Apache Pulsar contains multiple connectors for integrating with Apache Kafka. The Pulsar IO Apache Kafka Source Connector, Sink Connector, and Kafka Connect Adaptor Sink Connector log sensitive configuration properties in plain text in application logs.
This vulnerability can lead to unintended exposure of credentials in log files, potentially allowing attackers with access to these logs to obtain Apache Kafka credentials. The vulnerability's impact is limited by the fact that an attacker would need access to the application logs to exploit this issue.
This issue affects Apache Pulsar IO's Apache Kafka connectors in all versions before 3.0.11, 3.3.6, and 4.0.4.
3.0.x version users should upgrade to at least 3.0.11.
3.3.x version users should upgrade to at least 3.3.6.
4.0.x version users should upgrade to at least 4.0.4.
Users operating versions prior to those listed above should upgrade to the aforementioned patched versions or newer versions.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.pulsar:pulsar-io-kafka-connect-adaptor | all versions | 3.0.11org.apache.pulsar:pulsar-io-kafka-connect-adaptor:3.0.11 |
| ☕Maven | org.apache.pulsar:pulsar-io-kafka-connect-adaptor | ≥ 3.3.0&&< 3.3.6 | 3.3.6org.apache.pulsar:pulsar-io-kafka-connect-adaptor:3.3.6 |
| ☕Maven | org.apache.pulsar:pulsar-io-kafka-connect-adaptor | ≥ 4.0.0&&< 4.0.4 | 4.0.4org.apache.pulsar:pulsar-io-kafka-connect-adaptor:4.0.4 |
| ☕Maven | org.apache.pulsar:pulsar-io-kafka | all versions | 3.0.11org.apache.pulsar:pulsar-io-kafka:3.0.11 |
| ☕Maven | org.apache.pulsar:pulsar-io-kafka | ≥ 3.3.0&&< 3.3.6 | 3.3.6org.apache.pulsar:pulsar-io-kafka:3.3.6 |
| ☕Maven | org.apache.pulsar:pulsar-io-kafka | ≥ 4.0.0&&< 4.0.4 | 4.0.4org.apache.pulsar:pulsar-io-kafka:4.0.4 |
Affected Products
pulsarapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.pulsar:pulsar-io-kafka-connect-adaptor, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.pulsar:pulsar-io-kafka-connect-adaptor to 3.0.11 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-30677 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2025-30677 in your dependencies?
Find it across Maven, including transitive dependencies.