NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

Cross-Site Scripting in connectGHSA-rch9-xh7r-mqgw

MEDIUMFix: senchalabs/connect@6d5dd30

GHSA-rch9-xh7r-mqgw is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in connect. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for connect — see the affected versions and patch details below.

Also known asCVE-2018-3717
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
2 known
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.3%probability of exploitation in next 30 days
Lower Risk-0.02%
Lower risk than most CVEs71th percentile — riskier than 71% of all scored CVEsHighest risk
0.00%0.61%1.22%1.83%0.3%1.3%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

3Kother npm packages depend on this — each one inherits the vulnerability until it's patched upstream
connectnpm
29.5Mdownloads / week

Description

connect node module before 2.14.0 suffers from a Cross-Site Scripting (XSS) vulnerability due to a lack of validation of file in directory.js middleware.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmconnectall versions2.14.0npm install connect@2.14.0

Affected Products

1 product · 1 configurations
Application
connectsencha
< 2.14.0
range
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for connect, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update connect to 2.14.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-rch9-xh7r-mqgw is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

connect node module before 2.14.0 suffers from a Cross-Site Scripting (XSS) vulnerability due to a lack of validation of file in directory.js middleware.
O3 Security · Impact-Aware SCA

Is GHSA-rch9-xh7r-mqgw in your dependencies?

Find it across npm, including transitive dependencies.

Cross-Site Scripting in connect (Medium 5.4)