TensorFlow has Floating Point Exception in AvgPoolGrad with XLAGHSA-rcf8-g8jv-vg6p
HIGHFix: tensorflow/tensorflow@1295ae4GHSA-rcf8-g8jv-vg6p is a high-severity (CVSS 7.5) CWE-697 vulnerability in tensorflow. A fix is available for tensorflow — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-rcf8-g8jv-vg6p.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
tensorflow🐍tensorflow-cpu🐍tensorflow-gpuReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Impact
If the stride and window size are not positive for tf.raw_ops.AvgPoolGrad, it can give an FPE.
import tensorflow as tf
import numpy as np
@tf.function(jit_compile=True)
def test():
y = tf.raw_ops.AvgPoolGrad(orig_input_shape=[1,0,0,0], grad=[[[[0.39117979]]]], ksize=[1,0,0,0], strides=[1,0,0,0], padding="SAME", data_format="NCHW")
return y
print(test())
Patches
We have patched the issue in GitHub commit 1295ae4dbb52fe06b19733b0257e2340d7b63b8d.
The fix will be included in TensorFlow 2.12. We will also cherrypick this commit on TensorFlow 2.11.1.
For more information
Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.
Attribution
This vulnerability has been reported by r3pwnx of 360 AIVul Team
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | tensorflow | all versions | 2.11.1pip install --upgrade 'tensorflow==2.11.1' |
| 🐍PyPI | tensorflow-cpu | all versions | 2.11.1pip install --upgrade 'tensorflow-cpu==2.11.1' |
| 🐍PyPI | tensorflow-gpu | all versions | 2.11.1pip install --upgrade 'tensorflow-gpu==2.11.1' |
Affected Products
tensorflowgoogleDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for tensorflow, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update tensorflow to 2.11.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-rcf8-g8jv-vg6p is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-rcf8-g8jv-vg6p in your dependencies?
Find it across PyPI, including transitive dependencies.