GHSA-r6g8-mq9v-cgp4 is a high-severity (CVSS 7.5) CWE-732 vulnerability in froxlor/froxlor. A fix is available for froxlor/froxlor — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
froxlor/froxlorReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Froxlor through 0.9.39.5 has Incorrect Access Control for tickets not owned by the current user.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | froxlor/froxlor | all versions | 0.9.40composer require froxlor/froxlor:^0.9.40 |
Affected Products
froxlorfroxlorDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for froxlor/froxlor, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update froxlor/froxlor to 0.9.40 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-r6g8-mq9v-cgp4 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is GHSA-r6g8-mq9v-cgp4 in your dependencies?
Find it across Packagist, including transitive dependencies.