OpenStack Octavia Amphora-Agent not requiring Client-CertificateGHSA-r4v4-3jj7-jc29
CRITICALFix: openstack/octavia@1725517GHSA-r4v4-3jj7-jc29 is a critical-severity (CVSS 9.1) Improper Authentication vulnerability in octavia. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for octavia — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
octavia🐍octavia🐍octaviaReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Amphora Images in OpenStack Octavia >=0.10.0 <2.1.2, >=3.0.0 <3.2.0, >=4.0.0 <4.1.0 allows anyone with access to the management network to bypass client-certificate based authentication and retrieve information or issue configuration commands via simple HTTP requests to the Agent on port https/9443, because the cmd/agent.py gunicorn cert_reqs option is True but is supposed to be ssl.CERT_REQUIRED.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | octavia | ≥ 0.10.0&&< 2.1.2 | 2.1.2pip install --upgrade 'octavia==2.1.2' |
| 🐍PyPI | octavia | ≥ 3.0.0&&< 3.2.0 | 3.2.0pip install --upgrade 'octavia==3.2.0' |
| 🐍PyPI | octavia | ≥ 4.0.0&&< 4.1.0 | 4.1.0pip install --upgrade 'octavia==4.1.0' |
Affected Products
ubuntu linuxcanonicaloctaviaopendevResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for octavia, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update octavia to 2.1.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-r4v4-3jj7-jc29 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
There is no mitigation for this issue, the flaw can only be resolved by applying updates.Source: Red Hat security advisory for GHSA-r4v4-3jj7-jc29 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat OpenStack Platform 13.0 (Queens) | openstack-octavia-0:2.1.2-1.el7ost | RHSA-2019:3788 |
| Red Hat OpenStack Platform 14.0 (Rocky) | openstack-octavia-0:3.1.0-3.el7ost | RHSA-2019:3743 |
| Red Hat OpenStack Platform 15.0 (Stein) | openstack-octavia-0:4.1.2-0.20200114080449.5a71643.el8ost | RHSA-2020:0721 |
Frequently Asked Questions
Is GHSA-r4v4-3jj7-jc29 in your dependencies?
Find it across PyPI, including transitive dependencies.