CVE-2019-3895 is a high-severity (CVSS 8) CWE-284 vulnerability in octavia. A fix is available for octavia — see the affected versions and patch details below.
Openstack Octavia Access Control Vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
octaviaReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Description
An access-control flaw was found in the Octavia service when the cloud platform was deployed using Red Hat OpenStack Platform Director. An attacker could cause new amphorae to run based on any arbitrary image. This meant that a remote attacker could upload a new amphorae image and, if requested to spawn new amphorae, Octavia would then pick up the compromised image.
Mitigation
To prevent this vulnerability:
- Update Octavia's configuration setting (octavia.conf) to
amp_image_owner_id = $UUID_OF_SERVICE_PROJECTon all Octavia nodes. - Enable the new configuration by restarting both
octavia_workerandoctavia_health_manager.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | octavia | all versions | 0.9.0pip install --upgrade 'octavia==0.9.0' |
Affected Products
octaviaopenstackopenstackredhatDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for octavia, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update octavia to 0.9.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-3895 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
To prevent this vulnerability: 1. Update Octavia's configuration setting (octavia.conf) to `amp_image_owner_id = $UUID_OF_SERVICE_PROJECT` on all Octavia nodes. 2. Enable the new configuration by restarting both `octavia_worker` and `octavia_health_manager`.Source: Red Hat security advisory for CVE-2019-3895 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat OpenStack Platform 13.0 (Queens) | openstack-tripleo-common-0:8.6.8-11.el7ost | RHSA-2019:1742 |
| Red Hat OpenStack Platform 14.0 (Rocky) | openstack-tripleo-common-0:9.5.0-5.el7ost | RHSA-2019:1683 |
Frequently Asked Questions
Is CVE-2019-3895 in your dependencies?
Find it across PyPI, including transitive dependencies.