NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
MEDIUM severity

Podman Symlink VulnerabilityGHSA-r34v-gqmw-qvgj

MEDIUMFix: containers/libpod@5c09c4d

GHSA-r34v-gqmw-qvgj is a medium-severity (CVSS 5.5) CWE-59 vulnerability in github.com/containers/podman/v4. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for github.com/containers/podman/v4 — see the affected versions and patch details below.

Also known asCVE-2019-18466GO-2023-1942
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs72th percentile — riskier than 72% of all scored CVEsHighest risk
0.34%0.89%1.45%2.00%0.8%1.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐹github.com/containers/podman/v4

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

An issue was discovered in Podman in libpod before 1.6.0. It resolves a symlink in the host context during a copy operation from the container to the host, because an undesired glob operation occurs. An attacker could create a container image containing particular symlinks that, when copied by a victim user to the host filesystem, may overwrite existing files with others from the host.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/containers/podman/v4all versions1.6.0go get github.com/containers/podman/v4@v1.6.0

Affected Products

1 product · 1 configurations
Application
libpodlibpod_project
< 1.6.0
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/containers/podman/v4, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/containers/podman/v4 to 1.6.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-r34v-gqmw-qvgj is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

This issue did not affect the versions of podman as shipped with Red Hat Enterprise Linux 8 as they did not include support for the copy function. This issue did not affect the versions of podman as shipped in OpenShift Container Platform 3.11 and 4.1 as they did not include support for the copy function. The version…

ProductFixed inAdvisory
Red Hat Enterprise Linux 7 Extraspodman-0:1.6.4-16.el7_8RHSA-2020:1227
Red Hat Enterprise Linux 8container-tools:rhel8-8010020191126140055.c294d161RHSA-2019:4269

Frequently Asked Questions

An issue was discovered in Podman in libpod before 1.6.0. It resolves a symlink in the host context during a copy operation from the container to the host, because an undesired glob operation occurs. An attacker could create a container image containing particular symlinks that, when copied by a victim user to the host filesystem, may overwrite existing files with others from the host.
O3 Security · Impact-Aware SCA

Is GHSA-r34v-gqmw-qvgj in your dependencies?

Find it across Go, including transitive dependencies.

Podman Symlink Vulnerability (Medium 5.5)