NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

Cross-site Scripting in Apache ZeppelinGHSA-r2v5-5vcr-h3vq

MEDIUM

GHSA-r2v5-5vcr-h3vq is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in org.apache.zeppelin:zeppelin. A fix is available for org.apache.zeppelin:zeppelin — see the affected versions and patch details below.

Also known asCVE-2018-1328
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
6.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs93th percentile — riskier than 93% of all scored CVEsHighest risk
0.00%2.52%5.04%7.56%1.0%6.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.apache.zeppelin:zeppelin

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Apache Zeppelin prior to 0.8.0 had a stored XSS issue via Note permissions. Issue reported by "Josna Joseph".

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.zeppelin:zeppelinall versions0.8.0org.apache.zeppelin:zeppelin:0.8.0

Affected Products

1 product · 1 configurations
Application
zeppelinapache
< 0.8.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.zeppelin:zeppelin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.zeppelin:zeppelin to 0.8.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-r2v5-5vcr-h3vq is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Apache Zeppelin prior to 0.8.0 had a stored XSS issue via Note permissions. Issue reported by "Josna Joseph".
O3 Security · Impact-Aware SCA

Is GHSA-r2v5-5vcr-h3vq in your dependencies?

Find it across Maven, including transitive dependencies.

Cross-site Scripting in Apache Zeppelin (Medium 6.1)