NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2018-1317 — zeppelin

HIGH

CVE-2018-1317 is a high-severity (CVSS 8.8) Improper Authentication vulnerability in org.apache.zeppelin:zeppelin. A fix is available for org.apache.zeppelin:zeppelin — see the affected versions and patch details below.

Improper Authentication in Apache Zeppelin

Also known asGHSA-9x2h-hvg6-4r5p
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
4.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs92th percentile — riskier than 92% of all scored CVEsHighest risk
2.79%3.58%4.37%5.17%3.3%4.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.apache.zeppelin:zeppelin

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

In Apache Zeppelin prior to 0.8.0 the cron scheduler was enabled by default and could allow users to run paragraphs as other users without authentication.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.zeppelin:zeppelinall versions0.8.0org.apache.zeppelin:zeppelin:0.8.0

Affected Products

1 product · 1 configurations
Application
zeppelinapache
< 0.8.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.zeppelin:zeppelin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.zeppelin:zeppelin to 0.8.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-1317 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

In Apache Zeppelin prior to 0.8.0 the cron scheduler was enabled by default and could allow users to run paragraphs as other users without authentication.
O3 Security · Impact-Aware SCA

Is CVE-2018-1317 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2018-1317: zeppelin — Fixed in 0.8.0