NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
HIGH severity

XSS in VegaGHSA-r2qc-w64x-6j54

HIGHFix: vega/vega#3019

GHSA-r2qc-w64x-6j54 is a high-severity (CVSS 8.7) Cross-site Scripting (XSS) vulnerability in vega. A fix is available for vega — see the affected versions and patch details below.

Also known asCVE-2020-26296
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs77th percentile — riskier than 77% of all scored CVEsHighest risk
0.00%0.74%1.48%2.21%0.4%1.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

302other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
veganpm
1.9Mdownloads / week

Description

Vega is a visualization grammar, a declarative format for creating, saving, and sharing interactive visualization designs. Vega in an npm package. In Vega before version 5.17.3 there is an XSS vulnerability in Vega expressions. Through a specially crafted Vega expression, an attacker could execute arbitrary javascript on a victim's machine.

This is fixed in version 5.17.3

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmvegaall versions5.17.3npm install vega@5.17.3

Affected Products

1 product · 1 configurations
Application
vegavega_project
< 5.17.3
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for vega, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update vega to 5.17.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-r2qc-w64x-6j54 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant

In OpenShift Container Platform 4 (OCP) the openshift4/ose-logging-kibana6 container does package a vulnerable version of the vega library. However, for an attacker to successfully perform a reflected XSS attack an existing visualization must already exist and the details known to the attacker, as the visualization ID…

Workaround published by Red Hat
For Kibana which does contain the dependency vega, it is possible to turn of vega visualizations with `vega.enabled: false` in the kibana.yml
Source: Red Hat security advisory for GHSA-r2qc-w64x-6j54 (CC BY 4.0)

Frequently Asked Questions

Vega is a visualization grammar, a declarative format for creating, saving, and sharing interactive visualization designs. Vega in an npm package. In Vega before version 5.17.3 there is an XSS vulnerability in Vega expressions. Through a specially crafted Vega expression, an attacker could execute arbitrary javascript on a victim's machine. This is fixed in version 5.17.3
O3 Security · Impact-Aware SCA

Is GHSA-r2qc-w64x-6j54 in your dependencies?

Find it across npm, including transitive dependencies.

XSS in Vega (High 8.7)