NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

Bookstack Cross-site Scripting vulnerabilityGHSA-r2cf-8778-3jgp

HIGHFix: BookStackApp/BookStack@bbd1384

GHSA-r2cf-8778-3jgp is a high-severity (CVSS 8.7) Cross-site Scripting (XSS) vulnerability in ssddanbrown/bookstack. A fix is available for ssddanbrown/bookstack — see the affected versions and patch details below.

Also known asGHSA-ch37-ch8w-cfrq
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs66th percentile — riskier than 66% of all scored CVEsHighest risk
0.00%0.53%1.06%1.60%0.4%1.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘ssddanbrown/bookstack

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

In BookStack before version 0.30.4, a user with permissions to edit a page could insert JavaScript code through the use of javascript: URIs within a link or form which would run, within the context of the current page, when clicked or submitted. Additionally, a user with permissions to edit a page could insert a particular meta tag which could be used to silently redirect users to a alternative location upon visit of a page. Dangerous content may remain in the database but will be removed before being displayed on a page. If you think this could have been exploited the linked advisory provides a SQL query to test. As a workaround without upgrading, page edit permissions could be limited to only those that are trusted until you can upgrade although this will not address existing exploitation of this vulnerability. The issue is fixed in BookStack version 0.30.4.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistssddanbrown/bookstackall versions0.30.4composer require ssddanbrown/bookstack:^0.30.4

Affected Products

1 product · 1 configurations
Application
bookstackbookstackapp
< 0.30.4
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ssddanbrown/bookstack, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update ssddanbrown/bookstack to 0.30.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-r2cf-8778-3jgp is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

In BookStack before version 0.30.4, a user with permissions to edit a page could insert JavaScript code through the use of `javascript:` URIs within a link or form which would run, within the context of the current page, when clicked or submitted. Additionally, a user with permissions to edit a page could insert a particular meta tag which could be used to silently redirect users to a alternative location upon visit of a page. Dangerous content may remain in the database but will be removed before being displayed on a page. If you think this could have been exploited the linked advisory provid
O3 Security · Impact-Aware SCA

Is GHSA-r2cf-8778-3jgp in your dependencies?

Find it across Packagist, including transitive dependencies.

Bookstack Cross-site Scripting vulnerability (High 8.7)