NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

CVE-2022-0877 — bookstack

HIGHFix: bookstackapp/bookstack@856fca8

CVE-2022-0877 is a high-severity (CVSS 7.6) Cross-site Scripting (XSS) vulnerability in ssddanbrown/bookstack. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for ssddanbrown/bookstack — see the affected versions and patch details below.

Cross-site Scripting (XSS) - Stored in bookstackapp/bookstack

Also known asGHSA-5rcc-6cmj-7728
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 1, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs56th percentile — riskier than 56% of all scored CVEsHighest risk
0.00%0.43%0.85%1.28%0.3%0.8%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘ssddanbrown/bookstack

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Iframe tags don't have a sandbox attribute, this makes an attacker able to execute malicious javascript via an iframe and perform phishing attacks. The sandbox attribute will block script execution and prevents the content to navigate its top-level browsing context which will stop this type of attack.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistssddanbrown/bookstackall versions22.02.3composer require ssddanbrown/bookstack:^22.02.3

Affected Products

1 product · 1 configurations
Application
bookstackbookstackapp
< 22.02.3
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ssddanbrown/bookstack, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update ssddanbrown/bookstack to 22.02.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-0877 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Iframe tags don't have a sandbox attribute, this makes an attacker able to execute malicious javascript via an iframe and perform phishing attacks. The sandbox attribute will block script execution and prevents the content to navigate its top-level browsing context which will stop this type of attack.
O3 Security · Impact-Aware SCA

Is CVE-2022-0877 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2022-0877: bookstack — Fixed in 22.02.3