CVE-2020-11055 — bookstack
MEDIUMCVE-2020-11055 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in ssddanbrown/bookstack. A fix is available for ssddanbrown/bookstack — see the affected versions and patch details below.
Cross-Site Scripting in BookStack
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
ssddanbrown/bookstackReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Impact
A user with permission to create comments could POST HTML directly to the system to be saved in a comment, which would then be executed/displayed to others users viewing the comment. Through this vulnerability custom JavaScript code could be injected and therefore ran on other user machines.
This most impacts scenarios where not-trusted users are given permission to create comments.
Patches
The issue was addressed in BookStack v0.29.2.
After upgrading, The command php artisan bookstack:regenerate-comment-content should be ran to remove any pre-existing dangerous content.
Workarounds
Comments can be disabled in the system settings to prevent them being shown to users. Alternatively, comment creation permissions can be altered as required to only those who are trusted but this will not address existing exploitation of this vulnerability.
References
- BookStack Beta v0.29.2
- JVN#41035278
- BookStack Blog Post
For more information
If you have any questions or comments about this advisory:
- Open an issue in the BookStack GitHub repository.
- Ask on the BookStack Discord chat.
- Follow the BookStack Security Advice to contact someone privately.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | ssddanbrown/bookstack | ≥ 0.18.0&&< 0.29.2 | 0.29.2composer require ssddanbrown/bookstack:^0.29.2 |
Affected Products
bookstackbookstackappDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ssddanbrown/bookstack, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update ssddanbrown/bookstack to 0.29.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-11055 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2020-11055 in your dependencies?
Find it across Packagist, including transitive dependencies.