GHSA-qr6m-f3gv-8678 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in admidio/admidio. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for admidio/admidio — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
admidio/admidioReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Admidio 4.1.2 version is affected by stored cross-site scripting (XSS).
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | admidio/admidio | all versions | 4.1.3composer require admidio/admidio:^4.1.3 |
Affected Products
admidioadmidioResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for admidio/admidio, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update admidio/admidio to 4.1.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-qr6m-f3gv-8678 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-qr6m-f3gv-8678 in your dependencies?
Find it across Packagist, including transitive dependencies.