NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2022-23896 — admidio

MEDIUMFix: admidio/admidio@1ff30f7

CVE-2022-23896 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in admidio/admidio. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for admidio/admidio — see the affected versions and patch details below.

Cross-site Scripting in admidio

Also known asGHSA-qr6m-f3gv-8678
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 1, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs47th percentile — riskier than 47% of all scored CVEsHighest risk
0.00%0.36%0.72%1.07%0.2%0.6%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘admidio/admidio

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Admidio 4.1.2 version is affected by stored cross-site scripting (XSS).

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistadmidio/admidioall versions4.1.3composer require admidio/admidio:^4.1.3

Affected Products

1 product · 1 configurations
Application
admidioadmidio
< 4.1.3
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for admidio/admidio, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update admidio/admidio to 4.1.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-23896 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Admidio 4.1.2 version is affected by stored cross-site scripting (XSS).
O3 Security · Impact-Aware SCA

Is CVE-2022-23896 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2022-23896: admidio XSS — Fixed in 4.1.3