sweetalert2 v11.4.9 and above contains hidden functionalityGHSA-qq6h-5g6j-q3cm
GHSA-qq6h-5g6j-q3cm is a security vulnerability in sweetalert2. A fix is available for sweetalert2 — see the affected versions and patch details below.
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
sweetalert2npmDescription
sweetalert2 versions 11.4.9 and above are vulnerable to hidden functionality that was introduced by the maintainer. The package outputs audio and/or video messages that do not pertain to the functionality of the package and is not included in versions 11.0.0 - 11.4.8.
Workaround
Use a version 11.0.0 - 11.4.8 of the package until the maintainer releases a fix.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | sweetalert2 | ≥ 11.4.9&&< 11.22.4 | 11.22.4npm install sweetalert2@11.22.4 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for sweetalert2, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update sweetalert2 to 11.22.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-qq6h-5g6j-q3cm is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-qq6h-5g6j-q3cm in your dependencies?
Find it across npm, including transitive dependencies.