NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦 npm
Not in CISA KEV

sweetalert2 v8.19.1 and above contains hidden functionalityGHSA-8jh9-wqpf-q52c

GHSA-8jh9-wqpf-q52c is a security vulnerability in sweetalert2. A fix is available for sweetalert2 — see the affected versions and patch details below.

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Sep 24, 2025 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

3Kother npm packages depend on this — each one inherits the vulnerability until it's patched upstream
sweetalert2npm
1.2Mdownloads / week

Description

sweetalert2 versions 8.19.1 and up until 9.0.0 are vulnerable to hidden functionality that was introduced by the maintainer. The package outputs audio and/or video messages that do not pertain to the functionality of the package and is not included in versions below 8.19.1.

Workaround

Users who are unable to update to the fixed version (11.22.4) can use package versions 8.19.0 and below, as they do not contain the hidden functionality.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmsweetalert2≥ 8.19.1&&< 11.22.411.22.4npm install sweetalert2@11.22.4

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for sweetalert2, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update sweetalert2 to 11.22.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-8jh9-wqpf-q52c is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

`sweetalert2` versions 8.19.1 and up until 9.0.0 are vulnerable to hidden functionality that was introduced by the maintainer. The package outputs audio and/or video messages that do not pertain to the functionality of the package and is not included in versions below 8.19.1. ### Workaround Users who are unable to update to the fixed version (11.22.4) can use package versions 8.19.0 and below, as they do not contain the hidden functionality.
O3 Security · Impact-Aware SCA

Is GHSA-8jh9-wqpf-q52c in your dependencies?

Find it across npm, including transitive dependencies.

GHSA-8jh9-wqpf-q52c: sweetalert2 — Fixed in 11.22.4