NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

TensorFlow vulnerable to seg fault in `tf.raw_ops.Print`GHSA-qjqc-vqcf-5qvj

HIGHFix: tensorflow/tensorflow@6d423b8

GHSA-qjqc-vqcf-5qvj is a high-severity (CVSS 7.5) NULL Pointer Dereference vulnerability in tensorflow. A fix is available for tensorflow — see the affected versions and patch details below.

Also known asBIT-tensorflow-2023-25660CVE-2023-25660PYSEC-2026-1963PYSEC-2026-3231PYSEC-2026-3362
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 7, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-qjqc-vqcf-5qvj.

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs34th percentile — riskier than 34% of all scored CVEsHighest risk
0.00%0.30%0.60%0.89%0.2%0.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐍tensorflow🐍tensorflow-cpu🐍tensorflow-gpu

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Impact

When the parameter summarize of tf.raw_ops.Print is zero, the new method SummarizeArray<bool> will reference to a nullptr, leading to a seg fault.

import tensorflow as tf

tf.raw_ops.Print(input =  tf.constant([1, 1, 1, 1],dtype=tf.int32),
                            data =  [[False, False, False, False], [False], [False, False, False]],
                            message =  'tmp/I',
                            first_n = 100,
                            summarize = 0)

Patches

We have patched the issue in GitHub commit 6d423b8bcc9aa9f5554dc988c1c16d038b508df1.

The fix will be included in TensorFlow 2.12. We will also cherrypick this commit on TensorFlow 2.11.1.

For more information

Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.

Attribution

This vulnerability has been reported by Yu Tian of Qihoo 360 AIVul Team

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPItensorflowall versions2.11.1pip install --upgrade 'tensorflow==2.11.1'
🐍PyPItensorflow-cpuall versions2.11.1pip install --upgrade 'tensorflow-cpu==2.11.1'
🐍PyPItensorflow-gpuall versions2.11.1pip install --upgrade 'tensorflow-gpu==2.11.1'

Affected Products

1 product · 1 configurations
Application
tensorflowgoogle
< 2.12.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for tensorflow, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update tensorflow to 2.11.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-qjqc-vqcf-5qvj is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

### Impact When the parameter `summarize` of `tf.raw_ops.Print` is zero, the new method `SummarizeArray<bool>` will reference to a nullptr, leading to a seg fault. ```python import tensorflow as tf tf.raw_ops.Print(input = tf.constant([1, 1, 1, 1],dtype=tf.int32), data = [[False, False, False, False], [False], [False, False, False]], message = 'tmp/I', first_n = 100, summarize = 0) ``` ### Patches We have patched the issue in GitHub commit [6d423b8bcc9aa9f5554dc988c1c16d038b508
O3 Security · Impact-Aware SCA

Is GHSA-qjqc-vqcf-5qvj in your dependencies?

Find it across PyPI, including transitive dependencies.

TensorFlow vulnerable to seg fault in `tf.raw_ops.Print`