Langflow remote code execution vulnerabilityGHSA-qg33-x2c5-6p44
HIGHGHSA-qg33-x2c5-6p44 is a high-severity (CVSS 8.8) Code Injection vulnerability in langflow. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for langflow — see the affected versions and patch details below.
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
- A successful exploit gives an attacker total control of the affected component, not partial access.
Exploitation and automatability from CISA’s SSVC triage for GHSA-qg33-x2c5-6p44.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
langflowReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Langflow through 0.6.19 allows remote code execution if untrusted users are able to reach the "POST /api/v1/custom_component" endpoint and provide a Python script.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | langflow | all versions | 1.0.15pip install --upgrade 'langflow==1.0.15' |
Affected Products
langflowlangflowResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for langflow, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update langflow to 1.0.15 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-qg33-x2c5-6p44 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
How to detect GHSA-qg33-x2c5-6p44
A community-maintained Nuclei template exists for this CVE. You can scan for it directly:
nuclei -id ghsa-qg33-x2c5-6p44 -u https://target- Template
- Langflow <= 1.0.12 - Remote Code Execution
- Severity
- critical
- Impact
- Attackers can execute arbitrary code remotely, potentially leading to full system compromise.
- Remediation
- Update to the latest version of Langflow that addresses this issue or apply security patches.
Template by ProjectDiscovery nuclei-templates (0x_Akoko, pdteam), MIT licensed. View the full template. Scan only systems you are authorised to test.
Frequently Asked Questions
Is GHSA-qg33-x2c5-6p44 in your dependencies?
Find it across PyPI, including transitive dependencies.