Authentication bypass and denial of service (DoS) vulnerabilities in Apple Game Center auth adapterGHSA-qf8x-vqjv-92gr
HIGHFix: parse-community/parse-server@af4a041GHSA-qf8x-vqjv-92gr is a high-severity (CVSS 7.5) Improper Authentication vulnerability in parse-server. A fix is available for parse-server — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-qf8x-vqjv-92gr.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
parse-servernpmDescription
Impact
Weak validation of the Apple certificate URL in the Apple Game Center authentication adapter allows to bypass authentication and makes the server vulnerable to DoS attacks.
Patches
The vulnerability has been fixed by improving the URL validation and adding additional checks of the resource the URL points to before downloading it.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | parse-server | all versions | 4.10.10npm install parse-server@4.10.10 |
| 📦npm | parse-server | ≥ 5.0.0&&< 5.2.1 | 5.2.1npm install parse-server@5.2.1 |
Affected Products
parse-serverparseplatformDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for parse-server, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update parse-server to 4.10.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-qf8x-vqjv-92gr is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is GHSA-qf8x-vqjv-92gr in your dependencies?
Find it across npm, including transitive dependencies.