NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
HIGH severity

CVE-2022-24901 — parse-server

HIGHFix: parse-community/parse-server@af4a041

CVE-2022-24901 is a high-severity (CVSS 7.5) Improper Authentication vulnerability in parse-server. A fix is available for parse-server — see the affected versions and patch details below.

Authentication bypass and denial of service (DoS) vulnerabilities in Apple Game Center auth adapter

Also known asBIT-parse-2022-24901GHSA-qf8x-vqjv-92gr
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-24901.

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs53th percentile — riskier than 53% of all scored CVEsHighest risk
0.00%0.39%0.79%1.19%0.1%0.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

62other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
parse-servernpm
81Kdownloads / week

Description

Impact

Weak validation of the Apple certificate URL in the Apple Game Center authentication adapter allows to bypass authentication and makes the server vulnerable to DoS attacks.

Patches

The vulnerability has been fixed by improving the URL validation and adding additional checks of the resource the URL points to before downloading it.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
📦npmparse-serverall versions4.10.10npm install parse-server@4.10.10
📦npmparse-server≥ 5.0.0&&< 5.2.15.2.1npm install parse-server@5.2.1

Affected Products

1 product · 2 configurations
Application
parse-serverparseplatform
≥ 5.0.0 && < 5.2.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for parse-server, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update parse-server to 4.10.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-24901 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

### Impact Weak validation of the Apple certificate URL in the Apple Game Center authentication adapter allows to bypass authentication and makes the server vulnerable to DoS attacks. ### Patches The vulnerability has been fixed by improving the URL validation and adding additional checks of the resource the URL points to before downloading it.
O3 Security · Impact-Aware SCA

Is CVE-2022-24901 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2022-24901: parse-server DoS — Fixed in 4.10.10