NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

SaltStack Salt Permissions BypassGHSA-qcr3-hr2f-6557

HIGH

GHSA-qcr3-hr2f-6557 is a high-severity (CVSS 8.8) CWE-732 vulnerability in salt. A fix is available for salt — see the affected versions and patch details below.

Also known asCVE-2022-22941PYSEC-2022-174
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs71th percentile — riskier than 71% of all scored CVEsHighest risk
0.00%0.62%1.23%1.85%0.0%1.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐍salt🐍salt🐍salt

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

An issue was discovered in SaltStack Salt in versions before 3002.8, 3003.4, 3004.1. When configured as a Master-of-Masters, with a publisher_acl, if a user configured in the publisher_acl targets any minion connected to the Syndic, the Salt Master incorrectly interpreted no valid targets as valid, allowing configured users to target any of the minions connected to the syndic with their configured commands. This requires a syndic master combined with publisher_acl configured on the Master-of-Masters, allowing users specified in the publisher_acl to bypass permissions, publishing authorized commands to any configured minion.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIsaltall versions3002.8pip install --upgrade 'salt==3002.8'
🐍PyPIsalt≥ 3003&&< 3003.43003.4pip install --upgrade 'salt==3003.4'
🐍PyPIsalt≥ 3004&&< 3004.13004.1pip install --upgrade 'salt==3004.1'

Affected Products

1 product · 3 configurations
Application
saltsaltstack
≥ 3004 && < 3004.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for salt, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update salt to 3002.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-qcr3-hr2f-6557 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

An issue was discovered in SaltStack Salt in versions before 3002.8, 3003.4, 3004.1. When configured as a Master-of-Masters, with a publisher_acl, if a user configured in the publisher_acl targets any minion connected to the Syndic, the Salt Master incorrectly interpreted no valid targets as valid, allowing configured users to target any of the minions connected to the syndic with their configured commands. This requires a syndic master combined with publisher_acl configured on the Master-of-Masters, allowing users specified in the publisher_acl to bypass permissions, publishing authorized com
O3 Security · Impact-Aware SCA

Is GHSA-qcr3-hr2f-6557 in your dependencies?

Find it across PyPI, including transitive dependencies.

SaltStack Salt Permissions Bypass (High 8.8)