CVE-2022-22941 — salt
HIGHCVE-2022-22941 is a high-severity (CVSS 8.8) CWE-732 vulnerability in salt. A fix is available for salt — see the affected versions and patch details below.
SaltStack Salt Permissions Bypass
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
salt🐍salt🐍saltReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
An issue was discovered in SaltStack Salt in versions before 3002.8, 3003.4, 3004.1. When configured as a Master-of-Masters, with a publisher_acl, if a user configured in the publisher_acl targets any minion connected to the Syndic, the Salt Master incorrectly interpreted no valid targets as valid, allowing configured users to target any of the minions connected to the syndic with their configured commands. This requires a syndic master combined with publisher_acl configured on the Master-of-Masters, allowing users specified in the publisher_acl to bypass permissions, publishing authorized commands to any configured minion.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | salt | all versions | 3002.8pip install --upgrade 'salt==3002.8' |
| 🐍PyPI | salt | ≥ 3003&&< 3003.4 | 3003.4pip install --upgrade 'salt==3003.4' |
| 🐍PyPI | salt | ≥ 3004&&< 3004.1 | 3004.1pip install --upgrade 'salt==3004.1' |
Affected Products
saltsaltstackDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for salt, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update salt to 3002.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-22941 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2022-22941 in your dependencies?
Find it across PyPI, including transitive dependencies.