SilverStripe Web Cache Poisoning through HTTPRequestBuilderGHSA-q9ff-3q93-fm8m
MEDIUMFix: silverstripe/silverstripe-framework@107706cGHSA-q9ff-3q93-fm8m is a medium-severity (CVSS 5.9) CWE-444 vulnerability in silverstripe/framework. A fix is available for silverstripe/framework — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
silverstripe/framework🐘silverstripe/framework🐘silverstripe/frameworkReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Silverstripe CMS sites through 4.4.4 which have opted into HTTP Cache Headers on responses served by the framework's HTTP layer can be vulnerable to web cache poisoning. Through modifying the X-Original-Url and X-HTTP-Method-Override headers, responses with malicious HTTP headers can return unexpected responses to other consumers of this cached response. Most other headers associated with web cache poisoning are already disabled through request hostname forgery whitelists.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | silverstripe/framework | ≥ 4.0.0&&< 4.4.7 | 4.4.7composer require silverstripe/framework:^4.4.7 |
| 🐘Packagist | silverstripe/framework | ≥ 4.5.0&&< 4.5.4 | 4.5.4composer require silverstripe/framework:^4.5.4 |
| 🐘Packagist | silverstripe/framework | ≥ 3.0.0&&< 3.7.5 | 3.7.5composer require silverstripe/framework:^3.7.5 |
Affected Products
silverstripesilverstripeDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for silverstripe/framework, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update silverstripe/framework to 4.4.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-q9ff-3q93-fm8m is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-q9ff-3q93-fm8m in your dependencies?
Find it across Packagist, including transitive dependencies.