Liferay Portal Notifications Widget has multiple XSS vulnerabilities through various text fieldsGHSA-q8fj-76q7-4p7h
Fix: liferay/liferay-portal@0f1f6b6GHSA-q8fj-76q7-4p7h is a Cross-site Scripting (XSS) vulnerability in com.liferay:com.liferay.flags.web. A fix is available for com.liferay:com.liferay.flags.web — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-q8fj-76q7-4p7h.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
com.liferay:com.liferay.flags.webReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Multiple cross-site scripting (XSS) vulnerabilities in the Notifications widget in Liferay Portal 7.4.3.102 through 7.4.3.111, and Liferay DXP 2023.Q4.0 through 2023.Q4.5 and 2023.Q3.1 through 2023.Q3.10 allow remote attackers to inject arbitrary web script or HTML via a crafted payload injected into (1) a user’s “First Name” text field, (2) a user’s “Middle Name” text field, (3) a user’s “Last Name” text field, (4) the “Other Reason” text field when flagging content, or (5) the name of the flagged content.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | com.liferay:com.liferay.flags.web | ≥ 6.0.23&&< 6.0.24 | 6.0.24com.liferay:com.liferay.flags.web:6.0.24 |
Affected Products
digital experience platformliferayliferay portalliferayDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.liferay:com.liferay.flags.web, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update com.liferay:com.liferay.flags.web to 6.0.24 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-q8fj-76q7-4p7h is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-q8fj-76q7-4p7h in your dependencies?
Find it across Maven, including transitive dependencies.