GHSA-q2qw-rmrh-vv42 is a high-severity (CVSS 7.5) CWE-284 vulnerability in activejob. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for activejob — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
activejob💎activejob💎activejob💎activejobReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.
Description
A Broken Access Control vulnerability in Active Job versions >= 4.2.0 allows an attacker to craft user input which can cause Active Job to deserialize it using GlobalId and give them access to information that they should not have. This vulnerability has been fixed in versions 4.2.11, 5.0.7.1, 5.1.6.1, and 5.2.1.1.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 💎RubyGems | activejob | ≥ 4.2.0&&< 4.2.11 | 4.2.11bundle update activejob --conservative |
| 💎RubyGems | activejob | ≥ 5.0.0&&< 5.0.7.1 | 5.0.7.1bundle update activejob --conservative |
| 💎RubyGems | activejob | ≥ 5.1.0&&< 5.1.6.1 | 5.1.6.1bundle update activejob --conservative |
| 💎RubyGems | activejob | ≥ 5.2.0&&< 5.2.1.1 | 5.2.1.1bundle update activejob --conservative |
Affected Products
cloudformsredhatrailsrubyonrailsResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for activejob, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update activejob to 4.2.11 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-q2qw-rmrh-vv42 is resolved across your whole dependency graph.
Workarounds
Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| CloudForms Management Engine 5.9 | cfme-0:5.9.9.1-1.el7cf | RHSA-2019:0600 |
Frequently Asked Questions
Is GHSA-q2qw-rmrh-vv42 in your dependencies?
Find it across RubyGems, including transitive dependencies.