NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💎
💎 RubyGems
Not in CISA KEV
HIGH severity

CVE-2018-16476 — activejob

HIGHFix: rails/rails@970b0d7

CVE-2018-16476 is a high-severity (CVSS 7.5) CWE-284 vulnerability in activejob. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for activejob — see the affected versions and patch details below.

Improper Access Control in activejob

Also known asGHSA-q2qw-rmrh-vv42
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
1 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs87th percentile — riskier than 87% of all scored CVEsHighest risk
0.17%1.27%2.38%3.49%0.8%2.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
💎activejob💎activejob💎activejob💎activejob

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.

Description

A Broken Access Control vulnerability in Active Job versions >= 4.2.0 allows an attacker to craft user input which can cause Active Job to deserialize it using GlobalId and give them access to information that they should not have. This vulnerability has been fixed in versions 4.2.11, 5.0.7.1, 5.1.6.1, and 5.2.1.1.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
💎RubyGemsactivejob≥ 4.2.0&&< 4.2.114.2.11bundle update activejob --conservative
💎RubyGemsactivejob≥ 5.0.0&&< 5.0.7.15.0.7.1bundle update activejob --conservative
💎RubyGemsactivejob≥ 5.1.0&&< 5.1.6.15.1.6.1bundle update activejob --conservative
💎RubyGemsactivejob≥ 5.2.0&&< 5.2.1.15.2.1.1bundle update activejob --conservative

Affected Products

2 products · 5 configurations
Application
cloudformsredhat
1 version
4.6
Application
railsrubyonrails
≥ 5.2.0 && < 5.2.1.1
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for activejob, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update activejob to 4.2.11 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-16476 is resolved across your whole dependency graph.

  3. Workarounds

    Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
CloudForms Management Engine 5.9cfme-0:5.9.9.1-1.el7cfRHSA-2019:0600

Frequently Asked Questions

A Broken Access Control vulnerability in Active Job versions >= 4.2.0 allows an attacker to craft user input which can cause Active Job to deserialize it using GlobalId and give them access to information that they should not have. This vulnerability has been fixed in versions 4.2.11, 5.0.7.1, 5.1.6.1, and 5.2.1.1.
O3 Security · Impact-Aware SCA

Is CVE-2018-16476 in your dependencies?

Find it across RubyGems, including transitive dependencies.

CVE-2018-16476: activejob — Fixed in 4.2.11