Drupal core Denial of ServiceGHSA-pr99-c33p-fwf6
MEDIUMGHSA-pr99-c33p-fwf6 is a medium-severity (CVSS 5.3) vulnerability in drupal/core. A fix is available for drupal/core — see the affected versions and patch details below.
Real-World Exposure
drupal/core🐘drupal/coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
A visit to install.php can cause cached data to become corrupted. This could cause a site to be impaired until caches are rebuilt.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | drupal/core | ≥ 8.0.0&&< 8.7.11 | 8.7.11composer require drupal/core:^8.7.11 |
| 🐘Packagist | drupal/core | ≥ 8.8.0&&< 8.8.1 | 8.8.1composer require drupal/core:^8.8.1 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for drupal/core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update drupal/core to 8.7.11 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-pr99-c33p-fwf6 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-pr99-c33p-fwf6 in your dependencies?
Find it across Packagist, including transitive dependencies.