Plone Cross-site Scripting (XSS) vulnerabilityGHSA-pp4c-2692-7f37
MEDIUMGHSA-pp4c-2692-7f37 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in plone. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for plone — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
plone🐍plone🐍ploneReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Cross-site scripting (XSS) vulnerability in an unspecified page template in Plone CMS 5.x through 5.0.6, 4.x through 4.3.11, and 3.3.x through 3.3.6 allows remote attackers to inject arbitrary web script or HTML via unknown vectors.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | plone | ≥ 5.0&&< 5.0.6 | 5.0.6pip install --upgrade 'plone==5.0.6' |
| 🐍PyPI | plone | ≥ 4.0a1&&< 4.3.12 | 4.3.12pip install --upgrade 'plone==4.3.12' |
| 🐍PyPI | plone | ≥ 3.3 | No fix |
Affected Products
ploneploneResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for plone, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update plone to 5.0.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-pp4c-2692-7f37 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-pp4c-2692-7f37 in your dependencies?
Find it across PyPI, including transitive dependencies.