NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2016-7139 — plone

MEDIUM

CVE-2016-7139 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in plone. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for plone — see the affected versions and patch details below.

Plone Cross-site Scripting (XSS) vulnerability

Also known asGHSA-pp4c-2692-7f37PYSEC-2017-62
Published
Updated
Affected
3 pkgs
Patched
2 / 3
Exploits
1 known
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs76th percentile — riskier than 76% of all scored CVEsHighest risk
0.00%0.70%1.39%2.09%0.5%1.6%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐍plone🐍plone🐍plone

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Cross-site scripting (XSS) vulnerability in an unspecified page template in Plone CMS 5.x through 5.0.6, 4.x through 4.3.11, and 3.3.x through 3.3.6 allows remote attackers to inject arbitrary web script or HTML via unknown vectors.

Affected Packages

3 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIplone≥ 5.0&&< 5.0.65.0.6pip install --upgrade 'plone==5.0.6'
🐍PyPIplone≥ 4.0a1&&< 4.3.124.3.12pip install --upgrade 'plone==4.3.12'
🐍PyPIplone≥ 3.3No fix

Affected Products

1 product · 56 configurations
Application
ploneplone
52 versions
3.33.3.13.3.23.3.33.3.43.3.53.3.64.04.0.14.0.24.0.34.0.4
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for plone, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update plone to 5.0.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-7139 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Cross-site scripting (XSS) vulnerability in an unspecified page template in Plone CMS 5.x through 5.0.6, 4.x through 4.3.11, and 3.3.x through 3.3.6 allows remote attackers to inject arbitrary web script or HTML via unknown vectors.
O3 Security · Impact-Aware SCA

Is CVE-2016-7139 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2016-7139: plone XSS — Fixed in 5.0.6