FOSUserBundle Entropy is lost in the TokenGeneratorGHSA-pjx8-984p-7p3x
Fix: FriendsOfSymfony/FOSUserBundle@b3ebfeaGHSA-pjx8-984p-7p3x is a security vulnerability in friendsofsymfony/user-bundle. A fix is available for friendsofsymfony/user-bundle — see the affected versions and patch details below.
Real-World Exposure
friendsofsymfony/user-bundleReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Description
Because of the usage of base_convert which looses precision for large inputs, the entropy of tokens generated by FOSUserBundle for the email confirmation and password resetting is lost. This makes these tokens much less random than they are expected to be, and so not cryptographically safe.
Resolution
The token generation logic used in the 2.0.x branch based on base64 encoding has been backported. This changes the range of characters used in the token. Any route placeholder expected to match a token generated by FOSUserBundle must be updated to allow dashes, which are not allowed by \w in regexes. A \w+ requirement should so become [\w-]+.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | friendsofsymfony/user-bundle | ≥ 1.0.0&&< 1.3.5 | 1.3.5composer require friendsofsymfony/user-bundle:^1.3.5 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for friendsofsymfony/user-bundle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update friendsofsymfony/user-bundle to 1.3.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-pjx8-984p-7p3x is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-pjx8-984p-7p3x in your dependencies?
Find it across Packagist, including transitive dependencies.