CVE-2013-5750 — user-bundle
CVE-2013-5750 is a CWE-399 vulnerability in friendsofsymfony/user-bundle. A fix is available for friendsofsymfony/user-bundle — see the affected versions and patch details below.
FriendsOfSymfony FOSUserBundle denial of service via login form
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
friendsofsymfony/user-bundle🐘friendsofsymfony/user-bundleReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
The login form in the FriendsOfSymfony FOSUserBundle bundle before 1.3.3 for Symfony allows remote attackers to cause a denial of service (CPU consumption) via a long password that triggers an expensive hash computation, as demonstrated by a PBKDF2 computation.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | friendsofsymfony/user-bundle | ≥ 1.2.0&&< 1.2.5 | 1.2.5composer require friendsofsymfony/user-bundle:^1.2.5 |
| 🐘Packagist | friendsofsymfony/user-bundle | ≥ 1.3.0&&< 1.3.3 | 1.3.3composer require friendsofsymfony/user-bundle:^1.3.3 |
Affected Products
fosuserbundlefriends_of_symfony_projectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for friendsofsymfony/user-bundle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update friendsofsymfony/user-bundle to 1.2.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2013-5750 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is CVE-2013-5750 in your dependencies?
Find it across Packagist, including transitive dependencies.